Subject: VS2000/3100 SCSI Issues/BPF Questions
To: None <port-vax@NetBSD.ORG>
From: Jon Grubbs <jon_grubbs@INS.COM>
List: port-vax
Date: 06/30/1998 10:15:36
Good Day,

First off, a hearty thanks to those who have proceeded me in this quest and
have allowed me to get to as far I have.  Although it took over a year of
lurking on this list (my problem, not the project's!) I am ready to start
contributing what I can.

I was very proud of myself (and the VAX machines themseleves!) this weekend
when for the first time I had a stable KA650 system up and running and a
netbooted VS3100/M48 humming along at the same time.  Figuring I would see
what I could do with SCSI code for the 3100, I sup'ed current and compiled
a GENERIC kernel.  This was the first time I had gotten the kernel to
compile and work on the VAX port, so I was very excited!

Now, I uncommented out the ncr/sd stuff in the config file and tried again,
only to fail at the final linking, missing the routine 'uvax_phys2virt'.
Seems it is prototyped in uvax.h but is not actually in any of the code as
of this weekend.  I also notice that the other 'uvax_*' routines are
prototyped but missing.


Did I just pick a bad weekend to try to jump into the fray, or did these
routines accidentially get trashed somewhere along the way?  I noticed the
current code bears absolutly no resemblence to the code referenced earlier
this month by an unwilling contributor claiming to have found the holy
grail.  Any pointers would be appreciated.

In an unrelated issue, I decided using the KA650 for the bootserver (I am
already using it for the NFS server) would be better than using my FreeBSD
system so I tried getting the various services to start.  rarpd starts and
works fine.  mopd compiles ok, but doesn't seem to see any packets,
although moptrace does.  Lastly, I could not find bootparamd in the
binaries I had on the system, which I have to admit are about 3 months out
of date.  I would just sup the world, but my disk space (without the
VS3100!) is very limited.

So the questions are:

Are there any good reasons one can think of as to why the BPF code works
for rarp and moptrace (and tcpdump for that matter) but not for mopd?  This
is not a number of devices issue nor a /dev/bpf* issue.  The interface is a
'qe' interface.  Thought I would ask before I went digging around only to
find it was a trivial item I overlooked.

Did the binary set I downloaded a few months ago just overlook bootparamd,
or is it not part of the normal NetBSD distribution?

Thanks for any help you might be able to shed on these subjects.  Next
project is to netboot my second KA650 and then go looking for a way to
low-level format my RD54's without having a VS2000 :)

Jon Grubbs