Subject: Netbooting a VS2K
To: None <port-vax@NetBSD.ORG>
From: David Hamilton <>
List: port-vax
Date: 06/22/1998 11:53:29
I tried all weekend to get this to work...  Pehaps somebody can spot the
mistake I've made here:

I have 2 computers right now.  One is a linux box, one is a vs2k.  The linux
box has everything set up to allow for a netboot to be performed on the
vs2k.  I think.

The vs2k has 6 meg, the jumper has been set to make it think it's a mv2k,
and I'm using a vt220 on port 1 on the DEC port adapter.  It boots to VMS
off the RD5x just fine like this.  I have not removed the unused "4 plane"
graphics board if that's at all important.

Here's what I've done:

- recompiled the linux kernel to support rarp
- set up the linux box for ip address and called it
- added a rarp entry for the vs2000 for address 08.00.2b.0b.17.55 ->
- installed and ran mopd on eth0 (the mop format boot file is called
- added the vs2k to the hosts file, vs2000
- set up /netbsd/vax/boot for nfs mounting by vs2000 (rw, no_root_squash)
- enabled promisc on eth0 (everything works better this way...)

After all this:

- the v1.3.2 distribution was unpacked to /netbsd/vax/boot
- the v1.3.2 gennetbsd was copied to "/netbsd/vax/boot/netbsd"

After all that everything looks super-cool:

- the boot program loads with a >>> b/3 esa0, and waits for me to type
- I type /netbsd (or hit enter) and it:
    - gets it's ip address & name address
    - gets the server's ip address
    - finds it's root
    - loads the kernel
    - does a bunch of /^H-^H\^H|^H processing messages
    - says that it's starting at 0x???????? (some number I really should
have written down)
    - locks up (for at least 7 hours).  power must be cycled at this point.

I've also tried the mini root from the install directory, and that locks in
the same place (at kernel start).

If I try to boot /disklabel instead of /netbsd, disklabel comes up no
problem (woo-hoo.)

Do I need a different (not v1.3.2) kernel or something?

I saw this exact problem described before (on Sat, 05 Jul 1997 by Darrin
Wilson <> on a VS3100) in the archives, but there never
was a response (aside from "you can't use the graphics console").  Again,
I'm not using the graphics console.

Thanks for any help,