Subject: Re: Dilog SQ739, Micropolis 1588, and Me.
To: J. Buck Caldwell <>
From: Bob Harbour <>
List: port-vax
Date: 06/11/1998 18:28:03
On Thu, 11 Jun 1998, J. Buck Caldwell wrote:

> Just to test, I do: disklabel -w ra2 ra82
> after all, it was showing up as an ra82. It seemed to go fine, but when 
> I newfs'ed ra2a, it said rra2a: device not configured.
> So, I loaded up disktab and threw together a disklabel for the device, and 
> tried it again, optionaly trying -w -r as well. Still not configured. So I 
> shut down again to single-user, and tried
> re-writing the disklabel . Voila! no problems. Just to make sure, i did 
> disklabel ra0, to see what it wrote. rra2c: device not configured. Seems
> that I can access it once, and only once, per reboot.
> My next steps: first, try reformatting it (through the SCSI setup) and 
> re-labeling it, if the RA82 label might have screwed something up;  or yank 
> out the RQDX3 and re-install from scratch.

I just installed a SCSI disk on a Sigma SDC-RQD11-SCSI controller, and I
had some similar experiences. My controller called it an RA81, and when I
disklabel'd it accordingly, I could only access it once (using the -r in
disklabel). Once I had to put the drive on a PC and blast the label or it
would hang during boot. After starting with an empty label, I set it up
with correct parameters and then it disklabel'd and newfs'd fine. I also
re-named it to avoid any problems with disktab entries. I think that the
controller card or the driver will not allow accesses to a drive that is
not configured correctly for the cylinder/sector numbers. If you don't
use the -r parameter for disklabel, the numbers it returns are bogus.

Bob Harbour