Subject: 1.3E June 5 and VS2000.
To: NetBSD/vax Mailing List <port-vax@NetBSD.ORG>
From: Brian D Chase <>
List: port-vax
Date: 06/07/1998 01:17:03
Just for fun I've tried the latest kernel on a 6Meg VS2000, it seems to be
working okay.  At least from the standpoint that I'm currently writing
this e-mail from a login session on the VS2000 with the new kernel running
on it.  I've got a couple of questions though.

Here's what I pulled from my logs:

Jun  7 00:32:49 zutvax syslogd: restart
Jun  7 00:32:50 zutvax /netbsd: NetBSD 1.3E (GENERIC) #445: Fri Jun  5 23:55:34 CEST 1998
Jun  7 00:32:50 zutvax /netbsd:     ragge@subzero:/mnt/src/sys/arch/vax/compile/GENERIC
Jun  7 00:32:50 zutvax /netbsd: 
Jun  7 00:32:51 zutvax /netbsd: VAXstation 2000
Jun  7 00:32:51 zutvax /netbsd: realmem = 6278144
Jun  7 00:32:51 zutvax /netbsd: avail mem = 3528704
Jun  7 00:32:51 zutvax /netbsd: Using 306 buffers containing 313344 bytes of memory.
Jun  7 00:32:51 zutvax /netbsd: backplane0 (root)
Jun  7 00:32:52 zutvax /netbsd: cpu0 at backplane0: KA410
Jun  7 00:32:52 zutvax /netbsd: vsbus0 at backplane0
Jun  7 00:32:52 zutvax /netbsd: ln0 at vsbus0
Jun  7 00:32:52 zutvax /netbsd: ln0: address 08:00:2b:0b:7e:23
Jun  7 00:32:52 zutvax /netbsd: dz0 at vsbus0: DC367
Jun  7 00:32:52 zutvax /netbsd: lkc0 at dz0

  Does this mean that the LK201 is now supported under the VAXstation 2000
  as well as the VS3100?

Jun  7 00:32:52 zutvax /netbsd: smg0 at vsbus0
Jun  7 00:32:52 zutvax /netbsd: wsdisplay0 at smg0

  Same goes for the graphic display here.  Is this actually now supported
  on the VAXstation 2000, even if just accidentally through some good
  fortune that the VS2000 and VS3100s have the same type a mono
  framebuffer, or is the driver just loading regardless?  I know Ragge
  can't test this as he doesn't have access to a VS2000, but has anyone
  tried the graphic console on the VS2000 just for the sake of trying? :-)

  I would except that I don't yet have a monitor.

Jun  7 00:32:53 zutvax /netbsd: boot device: ln0
Jun  7 00:32:53 zutvax /netbsd: mountroot: trying nfs...
Jun  7 00:32:53 zutvax /netbsd: nfs_boot: trying RARP (and RPC/bootparam)
Jun  7 00:32:53 zutvax /netbsd: nfs_boot: client_addr=0xa03fa17
Jun  7 00:32:53 zutvax /netbsd: nfs_boot: server_addr=0xa03fa0a
Jun  7 00:32:53 zutvax /netbsd: nfs_boot: hostname=zutvax
Jun  7 00:32:54 zutvax /netbsd: root on opy:/usr/vax/zutvax
Jun  7 00:32:54 zutvax /netbsd: root time: 0x357a17a2
Jun  7 00:32:54 zutvax /netbsd: root file system type: nfs
Jun  7 00:32:54 zutvax /netbsd: init: copying out path `/sbin/init' 11
Jun  7 00:32:56 zutvax savecore: no core dump (no dumpdev)


One other thing I noticed.  With the 1.3 kernel (and perhaps earlier
kernels).  There was a problem on the VAXstation 2000 with its RTC.
Between reboots of the system, NetBSD would incorrectly reset the current
year to be 1970, the month, day, and time would however remain correct. 
This would happen even if the machine had only been halted and not power
cycled.  I run timed on the systems such that they'd pick up the correct
time from my network's timed master.  This tends to freak out cron since
it gets run before timed does (at least until you edit your startup

Well, that RTC problem seems to have gone away with the June 5th, 1.3E
kernel uploaded by Ragge.  I didn't pay enough attention to notice if this
was the case for the earlier 1.3E kernels, but it's a nice fix regardless.

So did this just fix itself?

Brian "JARAI" Chase | | VAXZilla LIVES!!!