Subject: Re: How About Some Images for 1.2G?
To: None <port-vax@NetBSD.ORG>
From: Bertram Barth <>
List: port-vax
Date: 06/21/1997 07:56:22
Brian D. Chase writes:
> On Fri, 20 Jun 1997, I myself wrote:
> > the point where they process the man pages.  I'm hoping that recompiling
> > the *roff commands will fix my problems (waiting on the compile as I
> > type).
> Nope, still broken... :-(  Perhaps something bad in the 1.2C libraries.  I
> was actually trying to compile the 1.2G libraries when I first ran into
> the problem.  Sort of catch-22 situation.  At least if getting the 1.2G
> libraries compiled actually will fix the *roff commands. When I
> subsequently recompile them.

Some general remarks:

First and most important: 1.2G is really an improvement over all the 1.2x
versions I had on my 3100, it works great! 

Swapping via nfs now works for me (thanks for the vax-specific modifcations
and for swapctl!), there are still some minor problems, but in general it
just works.

BTW: On my machine the kernel is more stable if i remove/change the 
     "#if !defined(vax)" line in vm_glue.c, I've still no clue what's
     happening there, but it seems to work...

You can avoid the nroff-hassle by "setenv NOMAN" before doing a build,
in that case the man-pages are not built and nroff is not used.

the nroff becomes stable if compiled without the "-O" flag, in my case
I just went into src/gnu/groff, did "make clean", "make CFLAGS=" and
"make install" and it worked.

After that I applied the patches for the last 2 days and did a complete
rebuild (after "setenv UPDATE" and "unsetenv NOMAN"). The result: it
completed without problems and the "time" command said:
    58994.89 real     37384.87 user     13263.61 sys

The chflags problem is/was nfs-related, for me it works since a few
weeks now without problems. If you still have these problems, getting
-current should fix it. (BTW: "make build" is the thing you should use).

All in all: I'm rather happy now! Thanks to all who made it happen!