Subject: Re: NetBSD/vax not swapping?!?
To: Bertram Barth <>
From: Johnny Billquist <bqt@Update.UU.SE>
List: port-vax
Date: 06/05/1997 15:06:17
> Today I started to check out some things on my VAXen and tried to
> compile some C++ files and ran into IMHO serious problems:
> It turned out that my 3100/76 running 1.2D doesn't swap at all!

Ah. I'm not alone!

I'm running 1.2E on a 3500, and swap don't work correctly there either.
However, when I have looked at the system, it has sometimes swapped
processes. Maybe it's a problem with releasing memory of swapped

I have not looked into it, since I normally can survive on 16M, but I
cannot run sup for example. A little irritating.

How do you manage to get any information from the system when you have run
out of memory? For me, the system hangs, period. I cannot execute any

> Surprisingly I could compile this file on my uVAX-II running 1.1A
> with 16MB. Here swapping works, with `vmstat` one can see that "po"
> and "sr" are really working.

Yes, I've run 1.1 on an 11/750, and that worked fine as well.

> I've no clue why this 3100 doesn't swap. Since it behaves the same
> with swap on sd0b and with swap on nfs, I'm now suspecting a general
> problem with 1.2D. Is there anybody out there who's 1.2D (or 1.2x)
> machine is swapping? What could be the reasons for the behaviour I get?
> Is this problem specific to the VAX port? Or even specific to 3100s?

Think it is a more general problem, but I have no clue to where it is.
Could be VAX specific though...

(Btw, how did you get those vmstat lists? vmstat won't run for me. Also, I
hope Ragge includes my fixes to get the CPU times correct. idle shouldn't
be 0% :-)


Johnny Billquist                  || "I'm on a bus
                                  ||  on a psychedelic trip
email:           ||  Reading murder books
pdp is alive!                     ||  tryin' to stay hip" - B. Idol