Subject: Re: getty repeating too quickly error
To: Kees Stravers <>
From: Ben Harris <>
List: port-vax
Date: 02/02/1997 20:18:31
On Sun, 2 Feb 1997, Kees Stravers wrote:

> A strange error happened when I tried to add a DHV-11 8 port serial card
> to my MicroVAX II running NetBSD 1.1. I put the M3104 in, strapped at the
> standard adress, I did ./MAKEDEV dhu0 in /dev and I changed one tty00 
> line in the /etc/ttys file, tty00 to ttyS0 and off to on. 
> Now when the machine boots, it says just after it changes the runlevel 
> from 0to 1:
> vax init: getty repeating too quickly on port /dev/ttyS0, sleeping
> vax init: getty repeating too quickly on port /dev/console, sleeping

I get exactly the same if I try to have more than one getty running on my
uVAX 3600 (running a -current of a few weeks ago).  At first I thought it
was the new dl device driver I'd added, but the same happens if I start up
one getty on the console and one on a ttyp?.  It only seems to happen if
the gettys are started when init starts; if you add them to /etc/ttys
while it's running and SIGHUP it, it works fine.  I can't remember what
signal it is that kills the gettys.  I think it may be SIGILL.  It also
affects other programs that I run (including halt in one case).  I haven't
attempted to track down the bug, since I don't intend to use my extra
serial ports for terminals anyway.

Ben Harris
Undergrad Computer Rep, Corpus Christi College, Cambridge.