Subject: v1.1B kernel build problems on uVAX II
To: None <port-vax@NetBSD.ORG>
From: Michael C Bednar <>
List: port-vax
Date: 04/21/1996 20:52:16

	I seem to be having more than a little bit of trouble building
a 1.1B kernel for my uVAX II. Here's the story: picked up the v1.1A binary
snapshot and got that up and running. Got the 1.1B src tarballs around the
beginning of April (don't remember the exact date), unpacked them onto a
spare disk in my VS3100/Ultrix machine, mounted the disk on the uVAX via
NFS and proceded to build the 1.1B dist. Built and installed everything
but the 1.1B kernel (had some problems, but nothing I couldn't work around).
Decided to try to build a 1.1B kernel to include Ultrix compatability.
Copied the GENERIC config file to a new name for my machine and proceded
to edit away. After a helpful pointer to the Ultrix support files for VAX
from ragge (thanks ragge!) and a bit more hacking I got a kernel built.
Unfortunately when I tried to boot it, it panic'd on me. Well, I figured
I'd touched something that would be better off being left alone, I decided
to start twiddling settings to see what woould happen. After a week and a 
half of this, still no joy. So thought I, perhaps there is an installation
problem/compiler problem/mysterious gremlin in the machine. Tried building
the generic kernel. Came back a day later and booted the new gennetbsd ker-
nel and it booted just fine. Hmmm...well, now try changing one thing at a
time and see when/what breaks. I changed the options GENERIC line to reflect
the name of my machine and the thing panic'd with a swapinit error. Well, ok
I'll change the line

	config          netbsd          swap generic


	config          netbsd          root on ra0a swap on ra0b

Now when I try to boot the kernel with these two changes I get:

   Trap: type 2, code 0, pc 8008faf9, psl 8
   P0BR 80000000   P1BR 80000000   P0LR        0   P1LR   200000
   KSP  800b52ac   ISP  80139400   USP         0
   R0   80093504   R1   8006b894   R2        901   R3   81c5bc00
   R4          0   R5          0   R6   8009e264   R7   8009e25c
   R8   800b538c   R9          1   R10         0   R11       101
   FP   800b5350   AP   800b536c   PC   8008faf9   PSL         8
   panic: trap: adr 0
   Stopped at      0x80090918:     bbs     $6, 60(r6), 0x80090920

right after the kernel finds my DHV11 serial boards and where it usually
outputs the message about the root device. Since a kernel build takes 2-3
hours minimum (what with make depend and all) I thought it might be time 
to see if there is some piece of common knowledge that I'm missing that
would save me some time from having to experiment for the next month or
two to find a kernel configuration that works.

Sorry to be so long winded.



What? Me speak for my employer?
They don't pay me enough for that...		            (412)624-6415