Subject: Re: Writing files to TK50 under 1.1A
To: None <, port-vax@NetBSD.ORG>
From: Carl Lowenstein <cdl@mpl.UCSD.EDU>
List: port-vax
Date: 04/11/1996 08:55:59
> Date: Wed, 10 Apr 1996 16:24:06 -0500
> From: Andrew Litt <>
> I've been trying to get my uVAXII with a TK50 to write out a binaries
> tape for NetBSD 1.1A. I had no problems doing this under VMS when I
> wrote out my first set of tapes (then 1.0). When I get about halfway
> through (about to the usr_bin.tar file) my tape drive spits up these
> messages:
> hard error bn341
> tape transfer error, unit 0, grp 0x0, event 0153
> hard error bn0: OFFLINE
> Now, I'm using the command dd if=foo.tar of=/dev/nrmt8 bs=512  to write
> the tape out. I've also tried combinations of using /dev/nrmt0 as well
> as using no specified block size, and there is no real difference in
> where it decides to abort. I've tried using a different tape, as well as
> cleaning out the drive. Nothing seems to keep it from writing the files
> to completion. 

Aha:  you are writing 512-byte blocks.  The inter-block gaps on the
tape will keep you from getting its full capacity.  Even a low-density
medium like 800bpi 9-track tape is 50% inter-block gaps with 512-byte

Back in the olden days, when Ultrix was new (v1.1), it came on TK50
tapes with something like 100kB blocks.  I ran some tests and found
that the use of such large blocks was overkill, but block sizes in the
16kB to 32kB range were reasonable.  The only data I can find lying
around from then showed a capacity of 2800 32kB blocks on a TK50, for
89600 kB total.  That is 91.75e6 bytes, or 91 advertising megabytes.

The rest of my results are backed up on a TK50 somewhere.  :-(

        carl lowenstein         marine physical lab     u.c. san diego
        {decvax|ucbvax} !ucsd!mpl!cdl