Subject: Writing files to TK50 under 1.1A
To: None <port-vax@NetBSD.ORG>
From: Andrew Litt <>
List: port-vax
Date: 04/10/1996 16:24:06
I've been trying to get my uVAXII with a TK50 to write out a binaries
tape for NetBSD 1.1A. I had no problems doing this under VMS when I
wrote out my first set of tapes (then 1.0). When I get about halfway
through (about to the usr_bin.tar file) my tape drive spits up these

hard error bn341
tape transfer error, unit 0, grp 0x0, event 0153
hard error bn0: OFFLINE

Now, I'm using the command dd if=foo.tar of=/dev/nrmt8 bs=512  to write
the tape out. I've also tried combinations of using /dev/nrmt0 as well
as using no specified block size, and there is no real difference in
where it decides to abort. I've tried using a different tape, as well as
cleaning out the drive. Nothing seems to keep it from writing the files
to completion. 

Two other points of interest: when I push the tape online button after
the write fails, the tape will do the typical slow 3-4 second rewind and
then the tape is ready for removal. I don't know exactly how TK50 drive
work, but my guess is that it will record to the end, move the heads one
track lower, and record backwards to the beginning, until it's filled up
all tracks. With an 8-track (i think) drive, this would mean that the
tape must have been full if it was at the beginning of the tape at the
error. The other interesting thing is that the normal mt commands work,
except for erase, retension, or status. Each of those gives me a device
not configured error. 

There's no why I can't just dd the entire distribution to tape. The .tar
files total to about 71 megs, and the TK50 has a 90 or so meg capacity.
I know either I set up my system wrong, or I'm messing something else
up. Any help is much appreciated!
 ::"If you wanna bake a cake, you::"My other brain is a Newton."-me::
  :: gotta bust a few heads!"-R&S :: :