Subject: Re: FW: Question/Help?
To: Robert D. Keys <>
From: Rick Copeland <>
List: port-sun3
Date: 10/05/1998 14:12:52

Is the SCSI VME card in the 3/110 a "SE" or a "SI"?  Both will work with
SunOS but only the "SI" will work with NetBSD right now.


At 04:38 PM 10/5/98 -0400, Robert D. Keys wrote:
>> [ On Mon, October 5, 1998 at 11:13:31 (-0700), Rick Copeland wrote: ]
>> > Subject: Re: FW: Question/Help?
>> >
>> > It looks like your Maxtor drives are SCSI, if this is the case you could
>> > low level format them by connecting them up to a PC with most any Adaptec
>> > SCSI controller and running the low level format.  I have a Sun 3/150 and
>> > have had to do that from time to time between botched installs.  
>> You don't need any PC to do this if you can boot SunOS somehow (eg. from
>> tape).  The SunOS format(8) command can "fix" any drive, and can indeed
>> low-level format any drive, though you probably don't have format it to
>> re-write the label with SunOS.
>It was SunOS that nuked them (mostly through my lack of feeding the
>proper values to it, and not knowing the correct sequence to follow).
>I did get one lone Quantum PD LPS240 finally to take a label and format
>and partition.  It now has SunOS-4.1.1 up on it.  What I will probably
>do is extend the internal cable out the top and up to a second box with
>the Maxtors and try that.
>Can anyone suggest a better, best, right, sequence of doing the format?
>I was assuming that it was disk, type, defect (to restore the manufacturer
>defect list), partition, format.  But, that sometimes worked and sometimes
>did not (mostly did not).  Why it worked on the one Quantum drive and not
>the 3 Maxtors is perplexing.
>Also, sometimes the label would take and other times it would not.
>The machine is a 12 bay VME case with a 3/110 cpu, a pair of 4M
>Carrera ram boards, and the internal scsi board.
>The scsi cable is properly terminated with the tape drive and its
>interface board terminators on the end of the cable.  The Quantum,
>or other drives were put on the remaining inboard connector.
>I sense it was something done out of proper sequence on the format
>and not any particular hardware problems.
>I have to assume the drives are toast (not properly labelled and
>formatted since they came from novell systems), and do a bottom-up
>setup of the drives, before use.  Somehow (well, anyhow)  I fed the
>wrong something somewhere to the format on the SunOS tapes and the
>drives are not correctly set up, label/format/table wise.  That is
>what I have to somehow correct.
>> The NetBSD disklabel(8) command should also be able to write a new label
>> without requiring the disk to be re-formatted, though I've not actually
>> done this with any recent NetBSD/sun3 (and if I remember correctly it
>> didn't work right in some earlier releases that couldn't write
>> Sun-boot-rom-compatible lablels -- in that case der Mouse's sunlabel
>> program should fix up your disks so they can be used as boot disks
>> again.)
>I could not get the edlabel to recognize the drives at all in the sun 3
>NetBSD install.  It kept coming back with ``drive not configured'' errors
>which I was assuming it was not reading a valid disk label to begin with.
>Where do I find der Mouse's sunlabel program?
>Thanks... and almost there.....
>Bob Keys