Subject: Re: cgfour0 giving a BIG display with Xsun
To: None <>
From: Scott Ellis <>
List: port-sun3
Date: 04/29/1996 09:23:54
In "Re: cgfour0 giving a BIG display with Xsun", "Don Koch"
<> wrote: 
> > The problem is, when I try and use Xsun, I get a BIG mono display which 
> > looks like it's made out of periods.  Hard to's maybe 64x64
> > resolution, in mono.  Very odd.  I checked the eeprom settings (using
> > eeprom),
> > and set console=color, scrsize=1152x900, rebooted, and nothing changed. ;-)
> Realize that the default background screen is the black and white stipple
> pattern you're seeing.  After starting X (via xinit or startx), try
> something like "xsetroot -solid red".

I'll give that a try, but I suspect I'll not see color. ;-)  The behaviour
I'm seeing isn't X in mono, it's like a zoomed-in section of XsunMono.
> If you've tried this and still get only black and white, see what X is linked
> to (xinit uses X, not Xsun or XsunMono).  Also verify that Xsun isn't a link
> to XsunMono.

X is Xsun (XsunMono works fine).

> Also try "X -help" for more options (like forcing the use of a particular
> frame buffer.

I tried "Xsun -dev /dev/cgfour0 -fbinfo", and fbinfo reports cgfour0
but the display still doesn't render correctly.

  //  Scott Ellis   //   //   //
// WARNING: This signature warps  time and space in its vicinity    //