Subject: Re: xdm strangeness, I'm really root?
To: Valtteri Vuorikoski <>
From: Paul Goyette <>
List: port-sun3
Date: 04/01/1996 07:53:04
On Mon, 1 Apr 1996, Valtteri Vuorikoski wrote:

> On Mon, 1 Apr 1996, Jari Kokko wrote:
> > Running the xdm binary and NetBSD 1.1B, I am really root as reported
> > by id -p and zsh's LOGNAME, that is: uid at login time. I first
> > noticed it when playing tetris, when the new high score was attributed
> > to root :)
>  I've noticed the same with both startx on console and remote MacX (xterm 
> started via rexec). uid is me, but login is root. For example ftp thinks 
> I'm root. Running ssh -v shows me:
> ssh_connect: getuid 666 geteuid 0 anon 0
>  My zsh shows LOGNAME correctly though.
>  This is NetBSD/mac68k-current with an oldish userland, so this isn't 
> sun3-specific.

I noticed this, too, when I tried to change my password!  Even though I 
was logged in as myself, the getlogin() call in passwd determined that I 
was root, and therefore wouldn't let me change my own passwd just by 
typing passwd.  I finally figured out that I could type passwd <username> 
and that worked just fine!