Subject: (a) new si driver; (b) make coredumping
To: None <mouse@Collatz.McRCIM.McGill.EDU>
From: Gordon W. Ross <>
List: port-sun3
Date: 10/31/1995 13:25:02
> Date: Tue, 31 Oct 1995 12:14:13 -0500
> From: der Mouse <mouse@Collatz.McRCIM.McGill.EDU>

> I've got a Sun-3/150 that I'm running NetBSD/sun3 on.
> First point: I'm using a kernel with gwr's new si driver.  It has
> worked fine for me, nary a peep of trouble, and is much faster than the
> old one (I can actually fsck the /usr/src partition, which is about 2G,
> in a tolerably short time now).  Thank you, gwr and whoever else is
> responsible for getting that code working!

Actually, most of the credit belongs to David Jones (I just help
debug it and port it to the OBIO version of "si" controllers).
I too am very grateful to David Jones for this contribution!

> Second point: I'm currently doing a rebuild of the world.  [...]
> [...normal libc make output, until...]
> 	cpp -DPROF -DNLS -DYP -DLIBC_SCCS -DSYSLIBC_SCCS -I/usr/src/lib/libc/include -D__DBINTERFACE_PRIVATE -DPOSIX_MISTAKE -DFLOATING_POINT -I/usr/src/lib/libc/arch/m68k /usr/src/lib/libc/arch/m68k/string/memset.S |  as -o memset.po
> 	Segmentation fault - core dumped
> 	*** Error code 139

> I investigated, and it was make, of all things, that coredumped.
> Anyone have any idea what's with make?  I intend to do yet one more
> build of the world once this one is done, and if the make installed by
> this build doesn't die, I won't worry about it.

I too have seen this problem with make, on occasion.  I could not
easily reproduce it.  A quick look at the core file produced:

	venus# gdb /usr/bin/make make.core
	GDB is free software [blah blah blah...]
	Core was generated by `make'.
	Program terminated with signal 11, Segmentation fault.
	Reading symbols from /usr/libexec/
	Reading symbols from /usr/lib/
	#0  0x17174 in Lst_Concat (l1=0x1dc7e0, l2=0x128ee0, flags=0)
	    at /home/gwr/src/usr.bin/make/lst.lib/lstConcat.c:146
	Source file is more recent than executable.
	146                 if (last != NilListNode) {
	(gdb) quit

That did not tell me anything obvious, so I rebuilt make with -g and
have been running that version.  No core dumps yet...

There was a change checked-in for make recently.
Maybe that fixed it...

In any case, the make problem existed before the new "si" driver.