Subject: Booting Sun3/50s
To: None <port-sun3@NetBSD.ORG>
From: Mailbox Internet <>
List: port-sun3
Date: 10/31/1995 15:36:39
Hmmm... anyone got any experience netbooting Sun 3/50s?

I have two of the beasts.

Both will boot quite happily of a SCSI disk I have with NetBSD on it.

One of them (called 'star') will boot off the network, booting of a SS20
running Sol 2.4.

The other however, manages this much:

It RARPS to get its IP addr, and then successfully tftp's the NetBSD 'netboot'
program.  It runs this (you see `>> NetBSD netboot [$ Revision $]`),
and then appears to be trying a second RARP - it says:

Requesting Internet Address for 8:0:20:1:A5:E4

And just sits there, for ever after...

However, if I run rarpd as in.rarpd -ad on the Sparc, it doesn't acknowledge a
second request.

I am by no means sure that this machines net boot system is correctly
configured - but it still doesn't work, even if I change /etc/ethers on the
sparc so that the second Sun3 thinks it is the first, it still doesn't boot.

Also, the second Sun3 get as far as it does rather more slowly than the first..

The only different I know of between the two is that the first has ROM rev 2.8,
and the second 2.0

Also the second has a 68882, and the first a 68881 - but they're
pin-compatible, right?

The eeproms could be different - and are, but I'm not sure if that matters,
sincethey both boot fine off SCSI.

Any ideas?

Julian Bean (

Mailbox Internet