Subject: Re: Isn't "db>" on boot bad? :P
To: <>
From: leam <>
List: port-sparc64
Date: 02/11/2003 20:42:49
leam wrote:
> Andrey Petrov wrote:
>> On Tue, Feb 11, 2003 at 05:13:25PM -0500, leam wrote:
>>> The reason for the "dump/restore" vice the other options is that I'm 
>>> trying to port a script from Solaris to NetBSD. The original script 
>>> does an fsck of the to-be-dumped-to partition, mounts it on /mnt, 
>>> dumps the twin partition from the live disk, and then umounts it.
>> Yeah, that seems easier with dump/restore. I'd suggest to verify 
>> copied partition by comparing it with original one,
>> if it fails i'd try -current.
>> And netbsd's dmesg or solaris's prtconf -pv would be helpful.
>>     Andrey
> Well, I tried again, and some different results but not the stellar 
> "login:" I'd hoped for. I re-dumped the "/" partition (the system is 
> basically idle), redid the bootblk, made sure the disklabels were the 
> same, and fsck'd the altboot partition.
> No luck. Booting either gave the fastdata MMU miss, or hung right after 
> the autobuild line. I copied the same kernel over, the same ofwboot, and 
> then even the original "off the 1.6 CD" kernel (which is what hung after 
> autobuild). I was unable to boot either in -s single user, "/ofwboot 
> do-boot", or even "boot sd1a:netbsd -s".
> I *know* this will work because I'm using the very things I'm booting 
> off disk0. So the kernel, init, and everything works. It just doesn't 
> wanna work on disk1.  :)
> Any more thoughts?

Urg, I'm replying to myself. What is it like, this "life" thing?????

Okay, I tried the installboot stanza from the man page and I get as far 
as the root filesystem is ffs, then

/bin/sh on /etc/rc terminated abnormally going to single user mode

Two seconds later it segfaults without giving me a chance to act in 
single user mode.

Is there a place that describes the boot sequence so I can see where I 
am and what it is bombing on? It seems like it's past loading the kernel 
and ofwboot, but is /bin/sh the problem or something else?