Subject: Re: booting from solaris
To: Eduardo Horvath <>
From: Andrei Petrov <>
List: port-sparc64
Date: 07/10/2000 16:55:54
On Mon, 10 Jul 2000, Eduardo Horvath wrote:

> I presume it's at /bsd/netbsd ?  Is it a 32-bit or 64-bit kernel?

I hope it's 64, here is my mk.conf:

CC=     gcc -m64
LD=     ld --oformat=elf64-sparc
TSORT=  tsort

> Using ufsboot used to work a while ago on 32-bit kernels.  It will not
> work with 64-bit kernels on solaris <2.7.  I have not tested it on
> anything newer so it may not work on 2.7 either.
> You can try passing the `-vVdD' options to the bootloader to see more
> diagnostic information.  You can also try using kadb to load the kernel to
> verify the ELF format.

if I do 'boot kadb -d' and after prompt '/bsd/netbsd'
then I get 
Size: 2120986+281256 Bytes
/bsd/netbsd loaded - 0x29e000 bytes used

I tried to check and to start it after that by everything I tried
led me into firmware prompt. I've got to learn some adb/kadb stuff.

> I strongly recommend generating an /ofwboot and using that to load the
> kernel.  However, even with that there may be filesystem issues on newer
> versions of solaris.
I think it may destroy my solaris. What do you think?

I saw the guy was able to netboot, so I'm trying to built ofwboot for
that purpose,
currently I lack crt0.o what kind of surprise me.

Should standalone program have crt0? Is my environment screwd?

> Eduardo Horvath				   

Thank you,