Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: OpenSSL issues with 9.2

Matt Wallis <mattw%madmonks.org@localhost> writes:

> Hi Folks,
> I’ve recently been working to get my Sparc IPXs back online. I got one of them to boot 9.1 via 
> NFS and had everything working. Including the excitement of a 7 hour wait during the first boot 
> for OpenSSH to generate host keys. :-)
> I then realised I hadn’t grabbed the latest version, and wanted to try a local disk install, so 
> grabbed the 9.2 install, mounted it via NFS and installed to a SCSI2SD device that I picked up to 
> replace the old HDD.
> Install went fine, but now it drops cores when using SSL for anything. The SSH startup fails, as 
> does pkgin, all with the same error.
> sparcy# pkgin install openssh
> assertion "(*wnumtop) == 0" failed: file "/usr/src/crypto/external/bsd/openssl/dist/crypto/bn/bn_div.c”, 
> line 439, function "bn_div_f"
> [1]   Abort trap (core dumped) pkgin install openssh
> sparcy# ssh-keygen
> Generating public/private rsa key pair.
> assertion "(*wnumtop) == 0" failed: file "/usr/src/crypto/external/bsd/openssl/dist/crypto/bn/bn_div.c”, 
> line 439, function "bn_div_f"
> [1]   Abort trap (core dumped) ssh-keygen

I installed a netbsd-9/sparc distribution built from sources updated on
May 12 into qemu using anita, and ran the self tests.   I then did
'anita interace' logged in as root and ran ssh-keygen, which worked.
openssl version reports:
  OpenSSL 1.1.1k  25 Mar 2021

I did not try pkgin and pkgsrc openssh.  Not sure this datapoint helps.

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index