Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Cannot boot sparc iso with qemu on Fedora 33

I'm trying to boot NetBSD sparc on Fedora 33/amd64 with Qemu 5.1.0 and it crashes.

I compiled my own iso and it crashed, so I tested it with the official one but also got the same results. I've also tried using a dump of the OpenBoot rom (ss5.bin) and gotten the same result.

This is the command line I used:

 qemu-system-sparc -drive file=wd0.vdi,if=scsi,bus=0,unit=0,media=disk -drive file=NetBSD-9.2-sparc.iso,format=raw,if=scsi,bus=0,unit=2,media=cdrom,readonly=on -boot d -nographic

It starts to boot and then crashes with the following output:

[   1.0000050] le0: 8 receive buffers, 2 transmit buffers
[   1.0000050] tcx0 at sbus0 slot 3 offset 0x800000 level 5 (ipl 9) (8-bit only TCX)
[   1.0000050] tcx0: SUNW,tcx, 1024 x 768
[   1.0000050] tcx0: id 0, rev 0, sense 0
[   1.0000050] tcx0: attached to /dev/fb0
[   1.0000050] system[0]: trap 0x29: pc=0xf0046c70 sfsr=0xb6 sfva=0x54000000
[   1.0000050] cpu0: data fault: pc=0xf0046c70 addr=0x54000000 sfsr=0xb6<PERR=0x0,LVL=0x0,AT=0x5,FT=0x5,FAV,OW>
[   1.0000050] panic: kernel fault
[   1.0000050] halted

halt, power off


I'm not sure what else to try. I tried on an iso I compiled of 9.1-stable and also got the same results. Maybe it's qemu 5.1, or maybe it's fedora?

I'd appreciate any insight you can give me -thanks!

Home | Main Index | Thread Index | Old Index