Subject: Re: sh core dumps
To: None <>
From: Henry Nelson <>
List: port-sparc
Date: 10/22/2005 11:57:04
> > It seem that I can reliably reproduce the problem with devel/gmake
> > after running make there I can cd to work/make-3.80 and trigger the
> > bug by running ./config.status.  That gives me one or sometimes two sh
> > core files (i run with kern.defcorename=3D%n.%p.core).  Both are from


> I ran that at least a hundred times on my Krups ( NetBSD dalwhinnie
> 3.99.9 NetBSD 3.99.9 (KRUPS) #1: Fri Sep 30 21:00:36 EDT 2005=20
> ml@Inishowen:/stuff/build/obj_sparc/sys/arch/sparc/compile/KRUPS sparc )
> with recent userland ( less than 2 weeks old ) and didn't get a single
> core dump. =20

What's going on?

Is everyone using the same version of the same compiler?  (Gcc is always
evolving; some releases work great, some not so great.  How gcc is
installed also is an important factor if everyone is not using the same
bundled gcc.)

Is everyone using the same header files?  (In the past I've tweaked the
distribution headers when NetBSD is the only Unix out there on which
some program won't compile.  Maybe others have done the same?)

Libraries, too.  (I totally nuke any NetBSD-distributed X and reinstall
from scratch.  It's amazing how many userland programs pull in stuff
from X headers and libraries.  Admittedly, gmake doesn't AFAIK.)

henry nelson
  day job <<