Subject: Re: TPE Port Problems on SS5
To: beaker <>
From: Bill Chiarchiaro <>
List: port-sparc
Date: 02/06/2003 20:27:39
beaker wrote:

> when it comes time to configure le0, it appears down, triggering a
> "lost carrier" error message. As mentioned, a ``test net'' command
> within OpenBoot results in the inner loopback test passing and the
> external loopback test failing. I've tried about everything I can
> think of and am assuming that this port is just dead.

I'll relate an experience I had recently with my SS5.

I had acquired some 32-MB DSIMMs for it, and I installed them along
with some of the machine's original 8-MB DSIMMs.  With the TPE port
cabled through a crossover to another machine, I had new, strange
behavior from le0.  On successive reboots or reconnections of the
cable, the link light on the other machine would either:

1) not light up
2) flash for an instant while connecting or disconnecting the cable
3) come on but blink off briefly in a periodic pattern
4) come on and stay on.

'ifconfig le0' on the SS5 always showed "no carrier."  I don't recall
what the OpenBoot tests showed.

It turns out that my recollection of which DSIMM slot was Slot 0
(J0300) had been incorrect.  That's the slot which is supposed to have
a DSIMM of the larger capacity when you've installed mixed DSIMMs.
After reshuffling the DSIMMs into the proper slots, le0 worked just

I wouldn't have believed it if I hadn't seen it.