Subject: Re: Sparc Boot Floppies
To: port-sparc <>
From: beaker <>
List: port-sparc
Date: 12/17/2002 01:29:56
> > I should mention that I _was_ able to use the 1.5.2 boot floppies to
> > create the disklabel, the newfs & dowonload/install the installation
> > binary sets, however it wouldn't let me download/install a kernel. When
> > the sets finished installing 'sysinst' prints a warning about the missing
> > kernel and says to install it manually - which I haven't a clue how to.
> > I tried rebooting with the floppies and running Update, but it seems
> > only want to get new binary install sets and not a kernel. I think
> > part of the problem is that the GENERIC kernels for 1.6 are not .tgz
> > files, so 'sysinst' doesn't "see" them (at least thats my theory). I did
> > notice that (with the 1.5.2 floppies) if I select X) off the initial menu
> > presented, I get dumped in the old familar i386-style sysinst menu. I
> > haven't yet tried reinstalling this way.
> It will work, but you have to change the kernel name from
> "kernel-GENERIC.tgz" to "kernel.tgz".  Or if you need to use one of the
> other two, you can change those.  OF course, this requires you to have a
> local FTP server to install from where you can change the names.
> I do, and it worked flawlessly.  I have a 1.6 system from the 1.5 floppys.

Just thought I'd post an update: I followed the advice above and was able
to install 1.6 on my IPX - Woohoo!

A few things to note:
- the permissions on the 'pub' directory had to be pretty loose for the
installer to actually fetch the sets. Perhaps something needed to be in
'bin' for some sort of conversion or ???
- kernel-GENERIC.tgz needs to be renamed to kern.tgz
- boot-device needs to be /sbus/esp/sd@3,0 , not /sbus/esp/sd@0,0
- for some reason /etc/resolv.conf didn't get created => make one
- if you change the hostname later on, change the 2nd field to the new
hostname in /etc/ifconfig.le0 .

Other than that, things went well and I'm up and running <"j

Beaker                /
                 o  /