Subject: sparc64 amd weirdness
To: None <>
From: Simon Gerraty <>
List: port-sparc
Date: 06/08/2001 15:43:51
At home I have 1.5 running on a couple of sparcs, which have no
trouble doing automounting from a 1.4.2 i386, nor does a freebsd

I'm still no closer to getting it to work on a sparc64 here at work.

Given the map:
/defaults            type:=link
*                    fs:=/home/callisto/${key}

/defaults            type:=nfs;opts:=rw,grpid,resvport,nodev
# /home/localhost always points /home/<machine>
localhost	     type:=link;fs:=${host}
callisto             type:=nfs;rhost:=${key};rfs:=/vol/vol2/homes
/defaults       type:=host;fs:=${autodir}/${rhost};rhost:=${key}
*               opts:=rw,grpid,resvport,nodev

referencing /homes/sjg/tmp should create:

/homes/sjg -> /home/callisto/sjg
/home/callisto -> /.amd/callisto/vol/vol2/homes

however what I get is:

ls: /homes/sjg/tmp: Input/output error

the link /homes/sjg -> /home/callisto/sjg is created ok, but nothing
is mounted, nor any link created in /home.

If I reference /host/callisto/vol/vol2/homes/sjg/tmp it works!

ls -ld /host/callisto/vol/vol2/homes/sjg/tmp
drwxrwxrwt  9 sjg  software  8192 Jun  7 15:11 /host/callisto/vol/vol2/homes/sjg/tmp/

local bits work fine:

ls -l /home/localhost
lrwxrwxrwx  1 root  wheel  6 Jun  8 15:38 /home/localhost@ -> hobbit

I've tried using amd.conf to force use of udp, nfsv2 etc etc, the
result is always the same.  ktrace doesn't show anything particularly

Callisto is a netapp btw, but I get the same result with other servers.
The client is an ultra1:

NetBSD 1.5Q NetBSD 1.5Q (HOBBIT) #2: Mon Jan 29 13:51:31 PST 2001 sparc64

any clues welcome.