Subject: UWS1/170E : Grabbing a disklabel
To: None <>
From: Steven Grunza <>
List: port-sparc
Date: 09/19/2000 14:07:45
Hash: SHA1

I'm trying to label a sparc64 disk from a i386 box.  I used the
port-i386 disklabel to write a label to the drive, then created file
systems with newfs -B be.  I then populated the file systems with the
appropriate files.  The Ultra PROM loader complained about a bad
magic number so I probably have an Endian issue with the disklabel.

For my next trick, I'm going to try dd'ing a few sectors off a
port-sparc disk in my SS1 and using dd's conv option to byte swap (or

I do have a Solaris 7 CD now but I can't get it to boot.  I've tried
"boot /sbus/fas/sd@6:f", to which the Ultra replies:

can't find netbsd
name of boot file [netbsd]?

Back when I was trying to netboot, I set boot-device to net and
boot-file to netbsd.  Now I can't set boot-file back to nothing and I
don't know what it should be for a standard Sun Solaris CD.  I've
tried boot, vmunix, unix, solaris, ofwboot, and a few others but none
have worked yet.

So, if anyone knows where on a sparc disk I can find the disklabel or
the name of the boot file on a Solaris 7 CD, I'd be real interested
in knowning....

Version: PGPfreeware 6.5.3 for non-commercial use <>


"Luke, you're going to find that many | Steven Grunza
of the truths we cling to depend      | voice:  (856) 787 - 2759 
greatly on our own point of view."    | fax:    (856) 866 - 2033
 - Obi Wan Kenobi, Return of the Jedi | e-mail: