Subject: Re: Serial console on SS2 under 1.4.1?
To: Brian D Chase <>
From: David Brownlee <>
List: port-sparc
Date: 10/31/1999 21:55:19
	Hmm - have you pulled the framebuffer, tried 'set-defaults', and
	tried setting the input-device and output-device again?
	I have a sparc2 here running 1.4 on serial console OK (well, its
	some way away, but I have a spiderport I can use to break into
	the prom :)

ok printenv
Parameter Name        Value                          Default Value

selftest-#megs        64                             
oem-logo?             false                          false
oem-banner?           false                          false
output-device         ttya                           screen
input-device          ttya                           keyboard
sbus-probe-list       0123                           0123
keyboard-click?       false                          false
ttyb-rts-dtr-off      false                          false
ttyb-ignore-cd        true                           true
ttya-rts-dtr-off      false                          false
ttya-ignore-cd        true                           true
ttyb-mode             9600,8,n,1,-                   9600,8,n,1,-
ttya-mode             9600,8,n,1,-                   9600,8,n,1,-
diag-device           net                            net
boot-device           disk                           disk
auto-boot?            true                           true
watchdog-reboot?      false                          false
fcode-debug?          false                          false
local-mac-address?    false                          false
use-nvramrc?          false                          false
screen-#columns       80                             80
screen-#rows          34                             34
sunmon-compat?        false                          true
security-mode         none                           none
security-#badlogins   2                              
scsi-initiator-id     7                              7
testarea              85                             0
mfg-switch?           false                          false
diag-switch?          false                          false


On Sun, 31 Oct 1999, Brian D Chase wrote:

> I've just upgraded a SPARCstation 2 from 1.3.2 to 1.4.1 and my serial
> console's gone all wiggy on me.  I've got a VT420 hanging off my sparc on
> the DB25 "A" serial port, and for the longest time now I've been using it
> as the console.  When I booted either the installation kernel or GENERIC
> kernel for 1.4.1, I can't use the terminal for input once the kernel takes
> over.  I can see the console output, but I have to plug in my type 4
> keyboard to enter anything.  The terminal works fine as the console
> when interacting with the boot prom.
> Just after the kernel loads, I'm dropped to the "ok" prompt with the
> following messages preceding the drop:
>   Warning: unparseable stdin-path property
>   Warning: unparseable stdout-path property
>   cninit: invalid inSource 0xffffffff
> At the "ok" prompt I go ahead and type "go" from the terminal.  The kernel
> continues booting just fine, but from this point on I have to plug in the
> type 4 keyboard to interact with the system.  The terminal still displays
> output the output and I can see the characters echo'ed from the sun
> keyboard on the terminal.
> Both my input-device and output-device variables are set to "ttya" which
> worked without problem under 1.3.2.
> How do I make this work?
> -brian.
> --- Brian Chase | | -----