Subject: Re: Problem with the lynx-ssl-patch on a sparc
To: None <>
From: Michael Pederson <>
List: port-sparc
Date: 10/14/1999 15:48:28
>I compiled lynx version 2.8.1 and 2.8.2 with ssl-patch (using
>SSLeay-0.9.0b) on pmax and on a Sparcstation 2. The patching and compiling

I've got lynx 2.8.2 w/ssl-patch built on an IPX.  I'm running
NetBSD/sparc-1.4.1 and have the OpenSSL package built.

>worked without any problem and lynx runs on both systems. I have only one
>problem when trying to make a ssl-commection from sparc. The
>apache/ssl_engine_log of a server I tried to make a ssl-connection to 
>listed below shows that it looks as if there are two connections that both
>fail (I didn't mail the BIO dumps; they are replaced by `...'s). The
>ssl-connections of the lynx on pmax work without any problems. Could anyone
>imagine what happened?

This goes with what I've run into here.  I initially built OpenSSL to
allow apache to do https connections, but attempting to launch it with
the ssl mod enabled resulted in a core dump (as does trying https via lynx).
I went back to the OpenSSL package, did a 'make test' and got some rather
curious results (there's a PR open on it).  In short, it looks like there's
a fault in egcs on some Sparc architectures, and SSL (both OpenSSL and
SSLeay) code trips over it.