Port-prep archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PCI expansion card working?

Hi! Tim,

From: Tim Rightnour <root%garbled.net@localhost>
Date: Tue, 15 Jan 2008 00:55:45 -0700 (MST)

> On 15-Jan-2008 KIYOHARA Takashi wrote:
> > I wanted to install those PCI cards.  However, the PCI card seems not to
> > be able to work correctly as for me. 
> You should be able to.  I have a quad-port fxp installed in one of my boxes,
> that seems to work fine.  However, when I tried to install an rl card on it,
> the rl card wouldn't function at all.  I suspect that the rl card isn't up to
> PCI specs.
> However, your cards sound like they should have worked to me.  Could you post 
> a
> dmesg of how the cards fail?

I saw some cards (vr, ex, aha) work.  I cleaned (physically ;-), and
inserted the card firmly politely for that.  And, there is a possibility
that one of the PCI slots of me is broken. (This machine has 2 slot)
The other operation is sometimes strange.

However I see the following messages at the same time as hanging up. 

    sd0(siop0:0:0:0): command timeout, CDB: 0x0a 04 37 57 02 00
    sd0(siop0:0:0:0): command timeout, CDB: 0x0a 04 37 59 02 00
    sd0(siop0:0:0:0): command timeout, CDB: 0x0a 04 37 97 08 00
    sd0(siop0:0:0:0): command timeout, CDB: 0x0a 04 41 47 08 00
    sd0(siop0:0:0:0): command timeout, CDB: 0x0a 04 27 b7 10 00
    sd0(siop0:0:0:0): command timeout, CDB: 0x08 05 89 c7 10 00

However, I cannot boot yet with fwohci(4). This cannot boot either slot. 
When it is a -current kernel that makes fwohci(4) enable, the following
messages are seen.

  Kernelized RAIDframe activated
  scsibus0: waiting 2 seconds for devices to settle...
                                                        <-- After a few seconds
  sd0(siop0:0:0:0): command timeout, CDB: 0x0a 04 37 57 02 00
                                                        <-- hung up


Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 4.0 (GENERIC) #0: Sun Dec 16 00:49:40 PST 2007
Model: IBM PPS Model 7248 (E)
total memory = 65536 KB
avail memory = 58604 KB
timecounter: Timecounters tick every 10.000 msec
mainbus0 (root)
cpu0 at mainbus0: 604 (Revision 3.4), ID 0 (primary)
cpu0: HID0 c084<ICE,DCE,SGE,BHT>, powersave: 1
cpu0: 133.33 MHz
pnpbus0 at mainbus0
wdc0 at pnpbus0: port 0x1f0-0x1f7 0x3f6, irq 13, DMA 6
atabus0 at wdc0 channel 0
wdc1 at pnpbus0: port 0x170-0x177 0x376, irq 13, DMA 7
atabus1 at wdc1 channel 0
mcclock0 at pnpbus0: port 0x70-0x71, irq 8: mc146818 compatible time-of-day 
nvram0 at pnpbus0: port 0x74-0x75 0x76
nvram0: Read 3118 bytes from nvram of size 4096
pci0 at mainbus0 bus 0: indirect configuration space access
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Motorola MPC105 "Eagle" Host Bridge (rev. 0x24)
pchb0: L2 cache: 512K, write-through mode
pcib0 at pci0 dev 11 function 0: IBM ISA Bridge w/PnP (rev. 0x02)
pcib0: PIRQ[0-3] not used
pcn0 at pci0 dev 12 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c970A PCnet-PCI II rev 6, Ethernet address 08:00:5a:f8:7c:23
pcn0: interrupting at irq 15
pcn0: 10base5, 10base5-FDX, 10baseT, 10baseT-FDX, auto, auto-FDX
vga0 at pci0 dev 14 function 0: S3 86C864-1 ("Vision864") (rev. 0x00)
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)
wsmux1: connecting to wsdisplay0
siop0 at pci0 dev 16 function 0: Symbios Logic 53c810 (fast scsi)
siop0: interrupting at irq 15
scsibus0 at siop0: 8 targets, 8 luns per target
ex0 at pci0 dev 22 function 0: 3Com 3c905-TX 10/100 Ethernet (rev. 0x0)
ex0: interrupting at irq 15
ex0: MAC address 23:b4:90:50:c2:65
nsphy0 at ex0 phy 24: DP83840 10/100 media interface, rev. 0
nsphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isa0 at pcib0
lpt0 at isa0 port 0x3bc-0x3bf irq 7
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
attimer0 at isa0 port 0x40-0x43: AT Timer
pcppi0 at isa0 port 0x61
isabeep0 at pcppi0
pcppi0: attached to attimer0
biomask a000 netmask a000 ttymask a082
timecounter: Timecounter "clockinterrupt" frequency 100 Hz quality 0
timecounter: Timecounter "prep_mftb" frequency 16666666 Hz quality 100
Kernelized RAIDframe activated
scsibus0: waiting 2 seconds for devices to settle...
sd0 at scsibus0 target 0 lun 0: <CONNER, CFP2105S  2.14GB, 1524> disk fixed
sd0: 2048 MB, 3940 cyl, 10 head, 106 sec, 512 bytes/sect x 4194304 sectors
sd0: sync (100.00ns offset 8), 8-bit (10.000MB/s) transfers, tagged queueing
cd0 at scsibus0 target 3 lun 0: <IBM, CDRM00203\000\000\000\000\000!K, BZ26> 
cdrom removable
cd0: sync (200.00ns offset 8), 8-bit (5.000MB/s) transfers
boot device: <unknown>
root device: sd0f^H ^H
dump device (default sd0b): 
file system (default generic): 
root on sd0a dumps on sd0b
root file system type: ffs
init path (default /sbin/init): 
init: trying /sbin/init

Home | Main Index | Thread Index | Old Index