Subject: Re: Weird float problem
To: None <>
From: Joel Reicher <>
List: port-pmax
Date: 05/18/2005 07:47:16
> I've got a DECsystem 5000/240 running NetBSD 2.0.2, and I'm having a weird
> problem with floats. For example, when I run uptime, I get corrupted output
> like this:
> # uptime
>  4:24PM  up  1:20, 1 user, load averages: 0.C, 0.1N, 0.12
> I get similar corruptions with w, top, and package version numbers (which
> really throws off pkgsrc). Has anyone else seen this problem, or know how
> to solve it?

Sorry for the late reply.

I've seen something similar. I had a DEC that was getting math
calculations wrong on other programs (ghostscript did funny things). I don't
think I tried the programs you name.

Anyway, it was a hardware problem. Don't know what caused it though; I don't
think the machine had been switched on for a while before I got to it. My
guess was that something had happened to some silicon. I concluded this
mainly because it was a fresh install, and I did an identical install on
another machine which worked fine.

If yours isn't a new install, perhaps your shared math library is
corrupted, although I'd expect random file corruption to cause the load
of the program to fail altogether.


	- Joel