Subject: re. Xpmax and TLB
To: None <>
List: port-pmax
Date: 12/02/2002 17:23:12
 hi all...

more info about Xpmax and TLB.

my machine is a 5000/133 with 32 megs of core. after a install
of 1.6 when startx was tried, got the same results that john
hawkinson at mit reported for 1.6_beta5. the first try of startx
got the error msg and returned to prompt. the second try at startx
got us into the debugger. and not knowing what to do here, it took
no effort at all to get a crash ;-}

figured how to write startup msgs to file, and every time X is
tried, also xdm, the log file shows:
 QIOCGINFO ioctl failed: Permission denied
 X connection to :0.0 broken (explicit kill or server shutdown).

push it into the debugger, and the opening coments there are:
 trap: TLB miss (load or intruction fetch) in kernel mode
 status=0xff34, cause=0x30000008, epc=0x8020f73c,Vaddr=0x2003c, pid=210
 cmd=Xpmax usp=0x7fffeaf8 ksp=0cc4089b30  Stopped in pid 210 (Xpmax)
 at uvm_mmap+0x134:  lw   vo,60(vi)

the above is hand logged.

the frame buffer is a PMAG-B. also tried a PMAGB-B with the same results.

suspecting that the new 'uvm' might have some little problems, tried
running some things that have large executables. installed a binary
package of ckermit (many thanks to whoever put this in pacakages),
and it runs just fine. finally got around to trying Xprt. that got

 Xp Extensions: could not find....yadi-yadi
 Fatal server error:
 no screens found

and the two lines of error out.. something about set{u,g}id pid 259... etc
returns with no problems or crash. printing is not configured in any
way here.

btw: since part 'a' of root drive is, was 64 megs and install put 32+ megs
here, there wasn't room for savecore to do it's thing. more learning
experiences ;-}