Subject: Re: Ailing 5000/260
To: Henry Bent <>
From: Chris Tribo <>
List: port-pmax
Date: 09/10/2001 08:40:46
On Sun, 9 Sep 2001, Henry Bent wrote:

> Anyhow, it was fine for the first few minutes, but then I was running a 
> pretty standard command ("ifconfig -A" if I recall) and it dumped me out to 
> the debugger.  I rebooted, ran the full set of tests, and came up with only 
> the following:
> "? TFL: 3/ni/ext-lb (3:(xmt [00000006])) [KN05]"

	This doesn't look like the failure command I get on my 240 when I
don't have a transceiver connected. IIRC it's TFL: 3/ni/ext-lb
(cable?) or some such. Each PROM is different though so I'm really not
sure. It looks more like some kind of ethernet controller failure. Too bad
there is no way to disable it (that I know of).

> So I said "boot" and this happened:
> --
> >>boot
> 1468632
> KN05 V2.1k  (PC: 0xa002cab8, SP: 0x8070fd50)

	It just spewed that number? Not the NetBSD first stage boot
loader and then the kernel magic numbers? Maybe you didn't "rst", see

> and then retried indefinitely, producing the same error over and over.  I 
> noticed that the RRD42 had a CD in it and was being accessed during boot 
> attempts; I ejected it and tried to boot again.  This time absolutely 
> nothing happened.  I then broke out of that and ran "cnfg 3" again and it 
> hung probing for SCSI disks.

	You must type "rst" to reset the system if it gets hung and dumps
you back into the PROM. Not resetting before trying things will get you
all sorts of strange and bizzare results. Also, the RRD42 flashes it's
activity light every time there is a SCSI bus reset. When you type boot
the first thing the PROM does is reset the SCSI bus, then the NetBSD
bootstrap resets the SCSI bus again, that was likely the activity you were
seeing on the drive, it's not actually transfering any information, just
doing it's own self test during the reset.

> So... what's the consensus on the problem?  Is it the SCSI controller, or 
> the RRD42 (my money's on that - flaky pieces of crap), or one of the disks? 

	You're kidding right? The RRD-42 is one of the only truely SCSI-2
compliant CD-ROM's that I have. I've used it to boot a Data General AViiON
and just about any system that needs 512 byte/block mode to boot. Sony and
Toshiba drives are more than decent IMHO. 

> Thanks all, and I hope I can save this.  I wouldn't want to have to get rid 
> of a top of the line DS or have to lose any of the data on the hard drives! 
> If any more info is needed, I can get it ASAP.

	My money is on the integrated ethernet controller, or improper
SCSI bus termination and termination power to bus settings.

	I'll take the CPU module! I also have a spare 5000/2x0 motherboard
sitting in my basement if you want to pay for shipping.