Subject: Re: New MI SCSI on 5000/200
To: Terry R. Friedrichsen <>
From: Jason Thorpe <>
List: port-pmax
Date: 03/07/2000 13:47:09
On Tue, 7 Mar 2000 14:24:25 -0700 
 "Terry R. Friedrichsen" <> wrote:

 > This is very odd - my 5000/200 will not boot into single-user mode with the
 > MI SCSI code.
 > After configuring the SCSI controllers xasc0 and xasc1, it configures sfb0
 > and then hangs forever, every time.

Here is my 5000/200:

Copyright (c) 1996, 1997, 1998, 1999, 2000
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 1.4T (SULACO) #72: Wed Feb 23 15:25:00 PST 2000
DECstation 5000/200 (3MAX)
total memory = 24576 KB
avail memory = 20236 KB
using 332 buffers containing 1328 KB of memory
mainbus0 (root)
cpu0 at mainbus0: MIPS R3000 CPU Rev. 3.0 with MIPS R3010 FPC Rev. 2.0
cpu0: 64KB Instruction, 64KB Data, direct mapped cache
tc0 at mainbus0: 25 MHz clock
ibus0 at tc0 slot 7 offset 0x0
mcclock0 at ibus0 addr 0x1fe80000: mc146818 or compatible
dc0 at ibus0 addr 0x1fe00000
le0 at tc0 slot 6 offset 0x0: address 08:00:2b:1e:a0:d9
le0: 32 receive buffers, 8 transmit buffers
le0: supplying EUI64: 08:00:2b:ff:fe:1e:a0:d9
xasc0 at tc0 slot 5 offset 0x0: NCR53C94, 25MHz, SCSI ID 7
scsibus0 at xasc0: 8 targets, 8 luns per target
unknown device AV01A-AA at tc0 slot 1 offset 0x0 not configured
cfb0 at tc0 slot 0 offset 0x0: 1024x864x8 console
scsibus0: waiting 2 seconds for devices to settle...
probe(xasc0:0:0): max sync rate 3.90Mb/s
sd0 at scsibus0 targ 0 lun 0: <DEC, RZ57     (C) DEC, 5000> SCSI1 0/direct fixed
sd0: 954 MB, 1928 cyl, 15 head, 67 sec, 512 bytes/sect x 1954050 sectors
IPsec: Initialized Security Association Processing.
boot device: <unknown>
root device: sd0
dump device (default sd0b): 
file system (default generic): 
root on sd0a dumps on sd0b
root file system type: ffs
le0: starting DAD for fe80:0001::0a00:2bff:fe1e:a0d9
le0: DAD complete for fe80:0001::0a00:2bff:fe1e:a0d9 - no duplicates found

 > The very first MI SCSI kernel I built worked, but it hasn't worked for me
 > since around time time of the kernel reorganization (though I wouldn't go
 > so far as to suggest a causal connection).

I haven't tried since the interrupt establish code was changed.  I suspect
that might be broken on the 5000/200.  I was going to try and test this
today, but my car broke down on my way out of the city this morning (I
normally take the train ... guess I picked a bad day to drive :-), so I'm
not in front of the machine right now...

        -- Jason R. Thorpe <>