Subject: xdm,etc probs
To: None <port-pmax@NetBSD.ORG>
From: Adam Fritzler <>
List: port-pmax
Date: 01/10/1998 13:15:36
Well, my new WD Enterprise 2.1gb drive came and I decided to move my Ultrix
machine to NetBSD (a nice weekend project, eh? :).

Everythings going surprisingly well, except for a few things...

1) xdm doesn't start properly
        Or, rather, the first X server started by xdm doesn't start
        properly.  If I start xdm anytime before init says:
                init: Kernel security level changed from 0 to 1...
        the first instance of X hangs on a inversed screen (b-on-w).
        But, if I immediatly telnet in and manually kill -9 that 
        X server, a new one starts and all is well!  Everything is
        also fine if i start xdm manually after logging into the console!

        What's the solution here?

2) Is there a version of bash that compiles and runs properly on NetBSD/pmax?
        I tried bash-2.01.1 and it configured and compiled fine, except for
        the fact that it says:

                free: Called with unallocated block argument
                Report this to
                Stopping myself...Abort trap - core dumped
        I'm going to try a 1.x version.  Is there a special place on for things that compile and work on NetBSD/pmax?
        (Besides /pub/NetBSD/arch/pmax/ported-software, which has nothing
        in it.)

3) This one probably is not pmax-specific, but is my lack of knowledge of
        shell scripts:  What's wrong with the following in rc.local:

        (sorry about long lines --is that the problem?)

        echo -n 'starting local daemons:'

        # add your local daemons here, following the startup models in /etc/rc

        echo -n ' httpd:80'; /usr/www/httpd-1.5.2/httpd -f
/usr/www/httpd-1.5.2/ conf/httpd.conf >& /dev/null
        echo -n ' httpd:8000'; /usr/www/httpd-1.5.2-8000/httpd -f /usr/www/httpd
-1.5.2-8000/conf/httpd.conf >& /dev/null
        echo -n ' httpd:8001'; /usr/www/httpd-1.5.2-8001/httpd -f /usr/www/httpd
-1.5.2-8001/conf/httpd.conf >& /dev/null
        echo -n ' httpd:8002'; /usr/www/httpd-1.5.2-8002/httpd -f /usr/www/httpd
-1.5.2-8002/conf/httpd.conf >& /dev/null
        echo -n ' httpd:8003'; /usr/www/httpd-1.5.2-8003/httpd -f /usr/www/httpd
-1.5.2-8003/conf/httpd.conf >& /dev/null

        When it executes this on startup, it says:
                <line#of second httpd>:Syntax error: bad fd number
        But, if I run it from a userspace shell, it runs fine.
        Can /dev/null not be written to during bootup (ie, sec level 0)?

Somebody help! :)


(  Adam Fritzler                            )