Subject: Re: odd disk problem
To: None <>
From: Arne Henrik Juul <>
List: port-pmax
Date: 05/22/1997 01:34:39
Michael L. Hitch wrote:
> > Upon reboot, my rz2 drive, an RZ-26 of some flavor, stopped the
> > SCSI configuration with "unknown phase 0x92".  The boot aborted
> > at that point.

I have a DS5000/25 that got this problem when I added another disk
recently.  It is *almost* consistent; I will sometimes be able
to get it to boot OK, and if it just goes past the initial
configuration, it will stay up even with heavy disk I/O.  The only
other symptom of trouble with asc driver is that I get these messages
	asc_intr: IN: dmalen 10 len 0 fifo 1
quite often whenever there is disk I/O.

I will try to get a really -current kernel compiled and tested on it
tomorrow to see if the problem persists.  I'm pretty sure that
termination, disks etc is all OK.  I have one internal and two
external disks, but I've tried without the internal disk, with only
the "offending" external one, and so on without any real differences.
I think there are some sort of initialization problems, because
it will always have problems on "reboot", but more often work
when I turn everything off and on, and sometimes trying to
boot from the offending drive (which makes it spin up, but fail
as there's no boot block there) will help.

>   That message is part of recent additions to display the reason for the
> "abort" and reboot by the ASC driver.  Previously, it was possible to have
> the system reboot with no message as to why.  I had seen this happen under
> certain configurations of SCSI disks connected externally.  If I can
> reproduce a failing configuration, and the reboot occurs for the same
> reason, then I may be able to figure out what's happening and possibly fix
> the driver.

I got these stops the first time I tried plugging the drive into the
chain, yes :-)  If you have any good ideas for debugging options and
so on I could try some, but I don't have a serial console so capturing
console debug output is awkward.

  -  Arne H. J.