Subject: lmbench and -current
To: None <port-pmax@NetBSD.ORG>
From: Simon Burge <>
List: port-pmax
Date: 04/10/1997 14:14:49
Hi people.

Has anyone tried building lmbench with -current?  I'm having problems
building the "lat_ctx" test, which has a huge unrolled loop in an
attempt to blow the instruction cache.

I've tried:

	cc					fails to build
	cc -static				fails to build
	cc -mno-abicalls -mno-half-pic		fails to run
	cc -static -mno-abicalls -mno-half-pic	fails to run

When it fails to build, I get the following errors:

	/var/tmp/cc016626.s: Assembler messages:
	/var/tmp/cc016626.s:3927: Error: Relocation overflow
	/var/tmp/cc016626.s:40061: Error: Relocation overflow

In the assembly code, the error at line 3927 is a branch to around line
40050, and the error at line 40061 is a branch to around line 3920.

When it fails to run, it seg faults after doing a few mmap/munmaps but
before main() starts (I guess it's doing the shared-library thing), as
well as the following ld message:

	ld: /var/tmp/cc0166391.o: linking PIC files with non-PIC files

Any ideas?