Subject: Re: partitioning problems
To: None <>
From: Andy Sparrow <>
List: port-pmax
Date: 02/08/1997 21:10:09

> Been having some problems partitioning an RZ56...the default scheme 
> worked, but didn't partition it as well as i would like it to. [yes, you 
> can start cringing now.] So i modified it a bit; basically, removed some 
> parititons i didn't want, and changed a partition to reflect it's new 
> size. Now, unless my math is completly wtrong or my calculator is broked 
> (or some combination thereof) shoul dbe fine.
> disktab entry:

Dislabel doesn't use the 'disktab' entry at all, AFAIK.

Use a proto file (one I hacked up quickly in 'ed' from the
miniroot for an RZ56 is attached, the nicer one with a 32Mb 
root partition and more partitions that I generally use is 
at home and the PPP link is down - sorry :).

Or use the sample one from the 'disklabel' tar archive on, suitably modified. Don't worry about the
comments on the end - they're always overwritten/generated
by 'disklabel' anyway.

I also attach the output of 'diskpart' for an RZ56 - note that you
should adjust down the size of both the last partition(s) and the 
'c' partition when entering them into a protofile, to protect the 
bad sector table at the end (I think).

The sizes you show in your disktab for 'c' are correct, AFAIK.

> # disklabel -w -B -b rzboot -s bootrz rz1 rz56           # (the disk i'm 
> 							 # trying to label is 
> 							 # on rz1; my bootstrap 
> 							 # disk is rz0)

When using 'disklabel' initially, I found it always core dumped unless I 
used the following form of the command:

disklabel -R -B /dev/rz?c <protofile>

(this may be when you run it against an Ultrix disk, e.g. one without
a NetBSD label, when some option implies reading the label, YMMV. I
didn't really bother mucking around with this once I got the label
on and the miniroot installed...)

I just worked down the list of options until I found a combination
that worked when trying to label an Ultrix disk. It's a lot less
touchy once there's a NetBSD label on the drive, BTW...

You don't need to specify the *boot* files, they'll be automatically
read out of '/usr/mdec', so just copy them there (there is no name 
collision with the single file Ultrix uses, and they haven't changed 
in a long time, far as I can gather). 

The above worked for me when I initially installed the NetBSD miniroot
from an Ultrix drive (and about 3-4 times since - I only have one
Ultrix disk left now :)

> needless to say, this is really annyoing me. no man pages, no 
> documentation, nothing.

There's a man page in the 'disklabel' tar archive, and a fair amount
of information/discussion in the mailing list about this.

I find that a good archive for the list is the URL

as this has gives you the capability to view the list archived by 

See also the FAQ and the installation guide on:

Good luck!



bumble# disklabel -r /dev/rz0c
# /dev/rz0c:
type: SCSI
disk: rz56
bytes/sector: 512
sectors/track: 54
tracks/cylinder: 15
sectors/cylinder: 810
cylinders: 1299174
total sectors: 1299174
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0           # milliseconds
track-to-track seek: 0  # milliseconds
drivedata: 0 

4 partitions:
#        size   offset    fstype   [fsize bsize   cpg]
  a:    32768        0    4.2BSD     1024  8192    16   # (Cyl.    0 - 40*)
  b:   131072    32768      swap                        # (Cyl.   40*- 202*)
  c:  1299174        0    unused     1024  8192         # (Cyl.    0 - 1603*)
  d:  1135334   163840    4.2BSD     1024  8192    16   # (Cyl.  202*- 1603*)

rz56: #sectors/track=54, #tracks/cylinder=15 #cylinders=1632

    Partition      Size  Offset    Range
        a         15884       0    0 - 19*
        b         66880   16200   20 - 102*
        c       1321920       0    0 - 1631
        d         15884  375030  463 - 482*
        e        307200  391230  483 - 862*
        f        622890  699030  863 - 1631
        g        946890  375030  463 - 1631
        h        291346   83430  103 - 462*