Subject: sigh
To: None <port-pmax@NetBSD.ORG>
From: Jon Mandrell <>
List: port-pmax
Date: 06/15/1995 22:30:05
I have a DEC 3100, with a color monitor.  I don't have Ultrix for it, so
it is currently dead, although I have lots of access to Sun machines.

I grabbed a boot.dd and miniroot off of, and then
did a 'cat boot.dd miniroot >/dev/rsd2c' to place it on the bare
Micropolis drive that I have.  The c partition had been set up to be
the entire disk under SunOS.  This appeared to work, and when I tried to
look at the disk via SunOS, it felt that there were no partitions, so
it looks like NetBSD and SunOS disagree on the formats.

At this point, I removed the disk from the Sun system, changed id's to 0,
and plugged it into the Dec.  i entered the command
	boot -f rz(0,0,0)netbsd
and the dec accessed the disk and then the boot monitor (V7.0) output
	Boot: rz(0,0,0)netbsd
	open(rz(0,0,0)netbsd) failed: -1
	Can't boot rz(0,0,0)netbsd
I tried using /netbsd, and it didn't work either.
I then tried 'boot -f rz(0,0,0)' and was told 'no aout header'.

So I went back to the Sun, repartitioned the disk so that I could see it,
and put on the miniroot first using dd with 'seek=16' thinking that
corrupting the SunOS label might have caused a problem.  I then dd'd
the boot.dd file onto the disk, moved over to the Dec, and got the
same results.

I'm assuming that something under the SunOS won't write the boot block
to the disk correctly, so I have been toying with the disk interface to
write absolute sectors to the disk.  Before I go through with this, does
it appear that I did anything grossly wrong in the above?  Is there anyone
out there that has tried to build a preliminary boot disk from a non-
Ultrix OS?

Any tips and pointers would be greatly appreciated.