Subject: Re: SCSI support
To: Christian Limpach <>
From: Goran Koruga <>
List: port-next68k
Date: 06/07/2002 10:16:55
On Thu, 6 Jun 2002 18:11:27 +0200, Christian Limpach wrote:

> good.  I now think it's probably just too much broadcast traffic which
> doesn't get handled fast enough.

Yeah it may well be. I am actually planning on using this machine at
home to replace my old 486, so I think it might work for me in that
scenario. But I'd like to install it at work where I have decent
internet connectivity - and for that I need a kernel that boots and
installs ;).

> hmm, there should actually be three bootp requests:
> - 1st from the NeXT rom monitor to load the boot program
> - 2nd from the boot program to load the kernel
> - 3rd from the kernel to mount root via nfs (after about 40s)

You're right - I have re-checked the log and it is like that. I must
have missed the 2nd one.

> So it fails when the kernel tries to mount root?  When I tried this
> earlier, this also happened here once but it worked when I made it try
> again (just hit return a couple of times when it asks for root/dump
> devices/types and such).  tcpdump on the server only showed the bootp
> request which worked. If you're using twisted pair to connect the
> machine, then another possibility would be the new code to select the
> ethernet media.  I've built a kernel with the media selection
> disabled:
> I've also added a printf, if you use twisted pair it should read
> "media: 90 d0" after the nfs_boot: trying DHCP/BOOTP line.

Thanks again for the kernel. I am using twisted pair, and it prints the
following :

media: 0 b0

Then it continues to boot, but it still doesn't finnish. It stopped with
the error message saying "no map available in nextdma_start()"

So we definitively have a good progress here - it looks like ethernet
media selection didn't work for me.

I have also noticed I have problems with swap. It complains about lack
of swap "WARNING no swap space configured!", fstab line is :

nfsserver:/usr/local/netbsd/swap   none  swap  sw,nfsmntpt=/swap

It also says "swapctl nfsserver:/usr/local/netbsd/swap: no such file or
directory". The file is there and showmount shows it too.

Not sure what is wrong here, but I don't think this has any negative
consequences since netbsd-generic boots with the same message.



Writing about music is like dancing about architecture.
    -- Frank Zappa