Subject: tftp: What??
To: None <,>
From: Michael Jinks <>
List: port-next68k
Date: 08/06/1999 18:57:28
Hi all.  I tried to get my NeXen to boot NetBSD a week ago and ran into
the RedHat NFS Problem.  Not having a spare i386 from which to generate
a NetBSD bootserver, I have instead thrown big iron at the problem, in
the form of an old (no other kind...) Sun 670MP SparcStation.

NetBSD works fine on the old horse.  Runs like a champ.  Unlike anything
from Sun.  If anybody here worked on that port, thankyou thankyou

But anyhow, now I try to use it as the boot server for the NeXen and of
course there is trouble.  This time, instead of getting hung up at NFS,
I'm getting hung up much earlier.  tftp refuses to spit the boot
loader.  The log:

Aug  6 18:49:11 hera bootpd[8598]: version 2.4.1
Aug  6 18:50:48 hera bootpd[8598]: requested path length > BP_FILE_LEN 
file = "boot", nul terminating

The relevant section of bootptab:


Contents of /tftpboot:

[root@hera /tftpboot]# ls -al
total 28
drwxr-xr-x   2 root  wheel    512 Aug  6 19:00 .
drwxr-xr-x  16 root  wheel    512 Aug  6 18:45 ..
-r-xr-xr-x   1 root  wheel  25896 Aug  6 18:46 boot
[root@hera /tftpboot]# file boot
boot: NetBSD/m68k executable

The output of the NeXT console is just "file not found", but it does
acknowledge my boot server by name, so at least it's getting that far.

hera is running NetBSD for sparc, version 1.4, no software added.

Thanks for any tips.  Something tells me we're real close to having this

A big, slow Beowulf waits in the wings...


All computers wait at the same speed...
       ...unless of course they are running Netscape...
mjinks - Enterprise Systems Engineer - at BSD,uchicago,edu