Port-mips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: current issues on Octeon (ER-4)


annoying about the root detection.  I don't have a good answer to
that part offhand, I'm afraid.  This is among the machine-
dependent code, and I guess it's the use of GPT for labeling
which the code isn't prepared to deal properly with.

> However, before long another problem emerged:
> netbsd-mips64# git --version
> [1]   Abort trap              git --version

I don't have a "real hardware" mipsn64-eb system going, but I do
have a VM run by qemu, and in my case this works nicely:

n64: {2} git status
On branch master
Your branch is up to date with 'origin/master'.

It took 7.88 seconds to enumerate untracked files. 'status -uno'
may speed it up, but you have to be careful not to forget to add
new files yourself (see 'git help status').
nothing to commit, working tree clean
n64: {3} uname -a
NetBSD n64 10.99.2 NetBSD 10.99.2 (MIPSSIM64) #3: Tue Jan  3 10:07:13 CET 2023  he%mt.urc.uninett.no@localhost:/u/build/HEAD/obj/evbmipsn64-eb/sys/arch/evbmips/compile/MIPSSIM64 evbmips
n64: {4}

(this is pkgsrc/wip)

However...  I wonder ... Since then, hasn't a new binutils been
imported and activated?  And can it have problems on this port?
I'm just guessing here...

> I tried to get a backtrace of this, but gdb did not recognize the git
> binary as something it knows how to run.

n64: {6} file /usr/pkg/bin/git
/usr/pkg/bin/git: ELF 64-bit MSB pie executable, MIPS, MIPS-III version 1 (SYSV), dynamically linked, interpreter /usr/libexec/ld.elf_so, for NetBSD 9.99.106, not stripped
n64: {7} gdb /usr/pkg/bin/git
GNU gdb (GDB)
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "mipsn64eb--netbsd".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/pkg/bin/git...
(No debugging symbols found in /usr/pkg/bin/git)

Hm, that's a binary for a newer kernel than what I run, but
looking at the package's +BUILD_INFO I built that myself while
running that version.  I appear to have downgraded, offhand I
cannot recall exactly why I did that, but I suspect I had

As for gdb actually working, I seem to recall that I had problems
with that as well on this host; where gdb itself crasahed.


- Håvard

Home | Main Index | Thread Index | Old Index