Subject: fftw_test failing on Core 2 Duo/GENERIC.MP
To: None <>
From: Brad du Plessis <>
List: port-i386
Date: 11/30/2007 09:22:39
Hi all,

On this system a few of days ago (Intel DG33FB, Intel 2180, 4.0_RC3 
GENERIC.MP) I encountered random segmentation faults when trying to 
build pkgsrc packages. The build would run for a while and would then 
die with a seg fault. I had a suspicion that the RAM may be faulty so I 
ran memtest-86 and it ran flawlessly for 2 hours.

I then built the benchmarking utility benchfft in 
pkgsrc/benchmarks/benchfft and I ran the app fftw_test on this system. 
After running fftw_test -r (2 of them, one for each core) for a couple 
of hours it reported a calculation failure. The second instance of 
fftw_test failed about an hour later.

I then tried fftw_test on all the hardware I could get my hands on (see 
the results below). I regard a system that can run this test for more 
than 24 hours as a pass. The systems where I've added "(1 core)" are 
dual core systems that have had the second core disabled in the BIOS. 
I've run memtest on the systems with the E2180 and the E2140 CPUs and no 
errors were found. The systems that passed were tested with 2 instances 
of fftw_test running at the same time, and were then retested with only 
one instance of fftw_test running.

Motherboard ; CPU ; Kernel ; Result

Intel DG33FB ; Intel E2180 ; 4.0_RC3 GENERIC.MP ; FAILED
Intel DG33FB ; (1 core) Intel E2180 ; 4.0_RC3 GENERIC.MP ; PASSED

Intel DG33FB ; Intel E2160 ; 4.0_RC4 GENERIC.MP ; FAILED
Intel DG33FB ; (1 core) Intel E2160 ; 4.0_RC4 GENERIC.MP ; PASSED

Intel DG33FB ; Intel E2140 ; 4.0_RC3 GENERIC.MP ; FAILED
Intel DG33FB ; (1 core) Intel E2140 ; 4.0_RC3 GENERIC.MP ; PASSED

Asus P5PE-VM ; Intel E6600 ; 3.1_RC2 GENERIC.MP ; FAILED
Asus P5PE-VM ; Intel E6600 ; 3.1_RC2 GENERIC ; PASSED

DFI G7V-600B ; Intel P4-3.0GHz ; 3.1_STABLE GENERIC ; PASSED
Intel DG31PR ; Intel Cel. 420 ; 4.0_RC3 GENERIC.MP ; PASSED

You'll note that what is a bit concerning is that no system running with 
both cores enabled passed this test. Has anyone else by any chance tried 
this on a Core 2 Duo system and seen similar results?

Is this something to worry about, or is this a bogus test?