Subject: Re: Thinkpad 760XD PCMCIA problems?
To: Greg Troxel , Tom Spindler <>
From: John D.Baker <>
List: port-i386
Date: 11/08/2007 20:43:03
I've tried values of RBUS_MIN_START from 0x06800000 (104MB), 0x08000000
(128MB), 0x10000000 (256MB), 0x20000000 (512MB) and then for 
0x40000000 (1GB) and 0x80000000 (2GB) with exactly the same results as

At Tom's suggestion, I tried a -current GENERIC.NOACPI kernel, but the
latest one to be had from the releng FTP mirrors is from 31 October.
The last time i386-current built successfully was 4 November 2007, but
these are completely absent from the FTP mirrors.

That said, the one from 31 October behaved identically to my custom
netbsd-4 kernel.  (I don't have space to build anything more myself.)

A  boot log with RBUS_MIN_START=0x08000000 and all the PCI debugging
turned on may be found at:

It's rather long.  First there's an initial boot to single-user.
Second, simply rebooting and disabling "cbb" and resulting crash when
a plain PCMCIA card is found.  Third, boot after power-cycle and
disabling "cbb" right away.

Maybe these will shed light on the issue?  Maybe there's something
that still needs configuring with the DOS-based "PS2" utility?

My PCI-fu is very rusty (and even when it was fresh, I worked almost
exclusively with i960Rx gadgets or PowerPC-based hardware where it
was our own code doing the probing and configuring of PCI devices...).


John D. Baker                            NetBSD     Darwin/MacOS X
http://mylinuxisp(dot)com/(tilde)jdbaker/     OpenBSD            FreeBSD
BSD.  It just sits there and _works_.
GPG fingerprint = D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645