Subject: acpi <> PCIBIOS_INTR_FIXUP?
To: None <>
From: Thomas Runge <>
List: port-i386
Date: 07/17/2005 14:18:32
Currently I got this really nice Dell D810 laptop. Of course
I installed NetBSD, but 2.0 didn't do it, because of some
very new devices that are supported on -current only.

Okay, let's try -current. Almost everything works quite nice
(see, except cbb(4). I can
use GENERIC_LAPTOP and everything works, including cbb. But
this machine has no apm. So, we need acpi and it seems, whenever
that option is enabled, PCIBIOS_INTR_FIXUP doesn't work anymore.
I tried almost every combination of all available FIXUPs,
including ACPI_PCI_FIXUP and ACPI_ACTIVATE_DEV, but to no

To verify, I first tried GENERIC_LAPTOP and then the same with
acpi enabled but no changes else. Same result:

cbb0 at pci3 dev 1 function 0: Texas Instruments product 0x8036 (rev. 0x00)
cbb0: NOT USED because of unconfigured interrupt
Texas Instruments product 0x8038 (miscellaneous communications) at pci3 dev 1 function 5 not configured

GENERIC_LAPTOP brings this:

cbb0: interrupting at irq 7
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 4 device 0
pcmcia0 at cardslot0

Full dmesgs:

As this machine has WLAN (iwi) and gigabit ethernet on board (bge),
I don't depend an cbb, but it would be nice to get it working

Did I miss somthing? Some secret option? :-)

Thank you!