Subject: NetBSD 2.0.2 - Processes take forever to start
To: None <>
From: Michael B. Trausch <>
List: port-i386
Date: 07/14/2005 12:32:33
Hash: SHA1

Hello everyone,

I have installed NetBSD 2.0.2 on my PC which is a 600 MHz Celeron with
192 megabytes of RAM and 30.0 GB of disk space.  Most things in the base
system run, however, I am running into a problem with (some) programs
not starting in a reasonable amount of time after typing the command on
the shell.

I am using bash 3.00 for my shell, although no matter which shell I use,
it doesn't seem to make a difference.  I didn't think that it would,
however, I did try just to make sure that something wouldn't have been
messed up with process control or something that might be causing the

The only two programs that I've noticed this happen on thus far are pine
(both from ports and built from source myself) and XFree86 that came on
the installer CD.  When I attempt to start pine it "stalls" in the
"poll" state for a very long time.  The same thing happens when I
startx, however, it happens to the 'xauth' program.

Here's the relevant output as seen from 'top' that shows the program
hanging.  I don't know if this will be helpful to anyone or not:

  104 fd0man     2    0  5780K 1436K poll       0:00  0.00%  0.00% pine
  106 fd0man     2    0   268K  912K poll       0:00  0.00%  0.00% xauth

That is from both of them.  I have yet to get pine to actually start,
and xauth hangs for a *very* long time both at startup of the X server,
and at shutdown.  I currently am only using twm because I don't want to
build something else only to find that I have to wait 4 times longer to
get the X display up and running.

If it helps, it seems that xauth hangs for approxamately five minutes
before returning letting the X startup process go forward, or dropping
you to the shell.

Has anyone else run into this?  I've googled for a few different things
trying to find information on this mysterious (to me) hanging problem.
I have tried searching for things specific to the 2.0.2 kernel and 2.x,
because I am not quite sure what it is hanging in.

I've also tried searching for things that are i386 specific, however, I
am not sure if that is the case, either.  This seemed to be the most
logical place to post.  I thank you in advance for giving advice and/or
direction.  :-)

Version: GnuPG v1.4.1 (MingW32)
Comment: Using GnuPG with Thunderbird -