Subject: Re: "/sbin/init failure" comes back!
To: None <>
From: Jukka Salmi <>
List: port-i386
Date: 05/10/2005 10:59:11
Samuel Lacas --> port-i386 (2005-05-10 10:06:21 +0200):
> the filesystem has been corrupted (/sbin/init was no longer a directory).

/sbin/init should _not_ be directory:

$ ls -l /sbin/init
-r-xr-xr-x  1 root  wheel  21710 Apr 22 14:23 /sbin/init

> 4) On a friend's advise, I tried to install a Linux on the first 
> I tried to reproduce the FS corruption, that is, I wrote a lot on the 
> FAT32 under NT and booted Linux, to see if file corruption appeared; to 
> no avail. Everything seems OK with both systems.

Did you newfs / format the FAT file system after seeing the corruption
with NetBSD and before not seeing it with Linux?

All things considered, this sound like bad hardware (RAM?) to me. Did you
already run memory tests?

In case you see corruption again, try restarting the system without
reformatting the file system in question. If the corruption is gone after
reboot, this is probably definitely bad hardware.

BTW, it's quite possible that Linux behaves differently compared with
NetBSD when run on falty hardware. Not seeing the problem with Linux does
not mean the hardware is OK ;-)

HTH, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~