Subject: "/sbin/init failure" comes back!
To: None <>
From: Samuel Lacas <>
List: port-i386
Date: 05/10/2005 10:06:21

After having spent two days this week-end on installation and pkgsrc 
building, I discovered yesterday, with quite a shock, that my /sbin/init
was again corrupted (kernel panic, debug, /rescue/init, etc.).
I really don't know what is going on. Here is what I remember of the 
full story (this is the second time it happens to me this month).

I have a 160Go maxtor HD, with three physical partitions: NetBSD (first 
half), NT (2/6) and a FAT32 one (remaining, at the end of the disk, 
which I planned to share between the two OSes).

1) As far as I remember, I installed NT first, then NetBSD. Everything 
went fine.
Due to some issues with my on-board network card, I exclusively used NT
during several weeks. One day, trying to reboot the NetBSD system since 
a long time, I got my first /sbin/init failure; after some inquiring, I 
discovered that
the filesystem has been corrupted (/sbin/init was no longer a directory).

2) Suspecting something wrong with the partition (could I have made an 
error?), I re-installed NetBSD on the first from scratch, with a 
particular attention on the partitions. Everything seemed OK.

3) Some days after, I discovered that the FAT32 partition under windows
has been corrupted: some files were unreadable, some had names which 
looked like perl scripts (!), etc. The ugly defrag' tools of NT was 
unable to "analyse" the disk, nor was "chkdsk". However, I don't know if
that corruption came from the NetBSD re-installation (step 2) or was 
caused by the previous one (step 1) and went unnoticed. In any case, I 
really wonder how the NetBSD and the FAT32 partitions could overlap, as 
there is the NT one between them (physically, I mean). Both the NT and 
NetBSD tools gave the same information on the partitions, without any 

Inquiring further, I noticed too that the FAT32 partition was broken
if I tried to access it from NetBSD: I could mount it, but the 
filesystem was "strange": some directories appeared as regular files and 
reciprocally, and files' contents were anyway garbled (text files 
appeared as garbage, etc.). The NT FS was cleanly readable from NetBSD.

4) On a friend's advise, I tried to install a Linux on the first 
partition, to see if the issue raised again. The install went fine, even 
better than the installed system (but I'm used to it, some Linux install 
programs seem to work better than the kernel they install -- end of flame).
I tried to reproduce the FS corruption, that is, I wrote a lot on the 
FAT32 under NT and booted Linux, to see if file corruption appeared; to 
no avail. Everything seems OK with both systems.

Now, I stuck with the bad feeling that, contrary to was I was thinking, 
NetBSD could be the only culprit, and that there was no partition issue 
at all. A friend also told me that I should have had installed NT on the 
first partition and that could be the origin of the problem, which I 
find really hard to believe; has someone heard of something similar?

Before trying to re-install NetBSD and test several rebootings to check 
if FS corruption occurs without NT, I want to have your opinion on this, 
should you have one :)

Sincerely yours,