Subject: networking problems
To: None <>
From: Joern Clausen <joern@TechFak.Uni-Bielefeld.DE>
List: port-i386
Date: 05/08/2005 21:14:10

I have several networking problems with one machine, which I guess are
somehow connected. Sorry for this lengthy, yet vague description, but I'd
like to give as many detail as possible.

First some specs, the machine is four or five years old:

NetBSD 2.0 (ROHAN) #1: Tue Dec 28 21:03:46 CET 2004
cpu0: AMD Athlon Model 2 (686-class), 648.78 MHz, id 0x621
rtk0 at pci0 dev 10 function 0: Realtek 8139 10/100BaseTX
ukphy0 at rtk0 phy 7: Generic IEEE 802.3u media interface
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

I use it as X11 client on a daily basis. Home directories and other
filesystems are served from a machine next to it. No problems so far.
What doesn't work is the following:

 - The other machine is my print server. Printing local from that
   machine or printing from a laptop works (i.e. /etc/printcap,
   spool directories and permissions on all machines are correct). If
   I print from my client, the jobs just hang in the queue and are
   never sent to the server. I can lpq and lprm them, but they never
   get printed. No hints in the log.

 - Most of the client's disk is unused, so I would like to NFS-export it
   as scratch filesystem. /etc/exports is set up, rc.conf has the right

rpcbind=YES             rpcbind_flags="-l"

   showmount -e shows that the fs is exportable, but I cannot access
   it from another machine. The reason: nfs is not registered with the
   portmapper (rpcinfo shows mountd and other NFS related serivces, but
   not nfs). I can "/etc/rc.d/nfsd forcestart" and everything works, but
   nfsd refuses to start on its own during boot. N.B. that the exact
   same configuration works for me on other machines.

It's all rather weired. The machine seems to be a good client, but sucks
as server (i.e. whenever it should initiate sending data to other
machines). I have no idea where to start looking. I tried another NIC,
but the problem remains. I tried the generic kernel, no change.  Any
ideas, anyone??

 Joern Clausen                   http://www.TechFak.Uni-Bielefeld.DE/~joern/