Subject: Re: boot problems on VIA Eden i586 board
To: David Laight <>
From: Dan LaBell <>
List: port-i386
Date: 03/10/2005 04:22:26
On Mar 6, 2005, at 4:38 PM, David Laight wrote:

>> They do indicate the Linux had bug in code handling machines without
>> PSE support. Perhaps same problem here?
> To my knowledge the netbsd code only uses features supported by the 
> i386
> since that is the book I used when writing the code.
> I also fixed some places where the old code didn't obey the rules!
> 	David
> -- 
> David Laight:
Also have an Via C3 Ezra, same problem, since it seemed video related I 
another video card, thinking it was vga bios or something, but it 
didn't help.
I also tried stepping thru via dos debug, which didn't work,  then for 
some reason I tried a reboot from dos via int 19. int 19 is boot 
failure, boots rom basic on org. PC's, on some pc's it breaks into cmos 
menu, in others reboots again after try again prompt, etc.   On mine, I 
discovered it boots from the disabled boot options, (kinda cool, no 
need to change bios setting to boot floppy, or cd),  and I got 2 error 
messages on the screen with my hang, instead of just messedup  display 
with a hang:

Boot-failed (errno 5): Can't open /boot

And also:

RPL-ROM-ERR : DE48 ; RPL Halted

Since dos, was loaded, etc, I tried booting 1.6 via same way as a 
control, and it worked.