Subject: Re: Linux emulation
To: NetBSD mailing list <>
From: Yasir Malik <>
List: port-i386
Date: 07/24/2004 12:18:57
Using the output from uname -r or -s didn't work.  I commented out the
line containing the OS names.  When I I ran the installer, it said
that since it didn't find the OS names, it wasn't going to bother checking
the OS.
The installation went fine.  I only had to edit some shell scripts.  It
also couldn't execute some Makefile targets; don't what that could lead
During the installation, the installer assumed that /emul/linux was my
root directory, so I mounted my partition within a subdirectory within
/emul/linux.  However, after installation, I tried to run one of the
and it naturally assumed my root directory was / and couldn't run any of
the programs because it couldn't fine Oracle's JVM.  I think this is
by installer programming using /emul/linux as my root directory.
Therefore I mounted the partition with Oracle within a subdirectory in /.
Now, None of the programs run because it can't find some libraries or the
programs keep getting NullPointerExceptions.