Subject: Re: Memory leak and Intel 82815 graphics
To: Andy Ruhl <>
From: Stephen Borrill <>
List: port-i386
Date: 07/21/2004 14:56:02
On Wed, 21 Jul 2004, Andy Ruhl wrote:
> > In the past (on 82810, 82810-DC100 and such like), I've always been able to
> > get X working by adding 'Options "NoDDC" "True"' and altering the VideoRam
> > settings. On this occasion, these tricks haven't worked. The installation
> > I'm trying to get this running on is a customised 1.6.2 installation with
> > mfs /dev and /var and disks mounted read-only. As I experimented, I noticed
> > that when I did a fresh 1.6.2 installation, it worked fine. Thinking that my
> > customisations might be messing something up, I tried adding bits in one at
> > a time to the stock installation. It turns out that simply untarring a large
> > archive is sufficient to kill X until a reboot, so I am lead to think it's a
> > memory fragmentation issue (c.f. USB umass devices). Using the mfs /dev and
> > /var at boot up seems to kill it every time.
> I'm not sure if I'm giving you the right information, but there was a
> similar problem when using anti aliased fonts in XFree86 a while back.
> I had it happen on my laptop. It would go into death spiral very
> quickly.

I think that's referring to an ongoing memory leak after X has started.
This problem is down to claiming the required video memory (the Intel
chipsets use a dodgy shared memory config where 1MB at most is allocated
by the BIOS and the rest has to tracked down by the driver) to start X in
the first place.

> Maybe try building and installing from current xsrc?

Yes, thought of that. I'll do it later, at the customers site FTP is
blocked. :-(