Subject: Re: Memory leak and Intel 82815 graphics
To: Stephen Borrill <>
From: Andy Ruhl <>
List: port-i386
Date: 07/21/2004 06:29:11
On Wed, 21 Jul 2004 11:26:44 +0100 (BST), Stephen Borrill
<> wrote:
> I've always been wary of Intel integrated graphics having had problems
> getting X running on them. This week, I've been trying to get X working on
> an 82815. It's failing with the following error:
> xf86BindGARTMemory: Bind key 10 at 0x00000000 (pgoffset 0)
> xf86BindGARTMemory: Binding of gart memory with key 10
>         at offset 0x0 failed (Cannot allocate memory)
> In the past (on 82810, 82810-DC100 and such like), I've always been able to
> get X working by adding 'Options "NoDDC" "True"' and altering the VideoRam
> settings. On this occasion, these tricks haven't worked. The installation
> I'm trying to get this running on is a customised 1.6.2 installation with
> mfs /dev and /var and disks mounted read-only. As I experimented, I noticed
> that when I did a fresh 1.6.2 installation, it worked fine. Thinking that my
> customisations might be messing something up, I tried adding bits in one at
> a time to the stock installation. It turns out that simply untarring a large
> archive is sufficient to kill X until a reboot, so I am lead to think it's a
> memory fragmentation issue (c.f. USB umass devices). Using the mfs /dev and
> /var at boot up seems to kill it every time.
> It is not currently possible to upgrade these machines to 2.0 as they are
> part of a suite at a customer's site.

I'm not sure if I'm giving you the right information, but there was a
similar problem when using anti aliased fonts in XFree86 a while back.
I had it happen on my laptop. It would go into death spiral very
quickly. Maybe try building and installing from current xsrc?